ATV Torture Forums banner

1 - 7 of 7 Posts

·
The Boss
Joined
·
4,362 Posts
Discussion Starter · #1 ·
ATV Product Review : Two Brothers M-7 Slip-on Exhaust System

The Two Brothers Racing exhaust systems have always caught my eye. I decided it was time to get one and put it through an ATVTORTURE.COM review. Having a Grizzly 700 test bike, I ordered the M-7 slip-on system.


First Impression


Attention to detail makes the Two Brothers Racing exhausts stand out among many other exhaust manufactures.

It is evident, even in the packaging of the M-7 that Two Brothers pays close attention to detail. The box the exhaust comes in would be suitable for protecting fine china. No way this exhaust could get damaged or scratched during shipping!

The M-7 V.A.L.E (Variable Axis Locking Exhaust) also features an exclusive Teflon-coated, blunted, cast magnesium outlet and exclusive X-Liteâ„¢ retaining ring which mates the mirrored polished head pipe to the canister. These exclusive Two Brothers Racing features not only look great, but also significantly reduce the weight of the exhaust system. The M-7 comes with a U.S.D.A. spark arrester installed along with the P1 power tip. It is the best looking exhaust system I have tested to date.

Click HERE to read more on the Two Brothers Racing M7 Exhaust System.
 

·
Registered
Joined
·
69 Posts
Crappp

hmm wish i would have saw this review about 2 weeks ago. i just got a hmf swamp series and optimizer. i also have a dynatek cdi. i havnt got it tuned in perfect yet but so far im not impressed at all. it almost seems like i lost alittle. i just noticed on the highlifter forum that almost every one ran it so i assumed that it worked the best. on the dynos the t.b. makes slightly more hp than the hmf does even with the optimizer.:confused:
 

·
Premium Member
Joined
·
537 Posts
hmm wish i would have saw this review about 2 weeks ago. i just got a hmf swamp series and optimizer. i also have a dynatek cdi. i havnt got it tuned in perfect yet but so far im not impressed at all. it almost seems like i lost alittle. i just noticed on the highlifter forum that almost every one ran it so i assumed that it worked the best. on the dynos the t.b. makes slightly more hp than the hmf does even with the optimizer.:confused:
Are you sure that your optimizer is set properly? Also you may need to add more air.
 

·
Registered
Joined
·
69 Posts
optimizer settings

well i think they are at 2.5,2.5,3.5 as of right now. i didnt even get to hardly play with it. i checked the plug and its just alittle rich but i didnt get to pull it yet on a WOT run or half yet. also i noticed while holding the throttle roughly 1\2 throttl or enough to keep it rolling about 40 mph it has a surge to it. like it wants to go but cant. then you smack the throttle and it just doesnt seem to pull very hard. i have a k&n filter and i modified the air box lid. i cut a hole similar to the ehs lid but i got a prefilter off of an automotive filter (i work at napa) roughly 1\2" thick and put it over my cut out. maybe its still not getting enough air?? i was on limited time last weekend so i didnt have a chance to get some accurate plug readings yet to see exactly how it burning. but honestly it doesnt feel as good as stock anywhere through the RPMS. what are the odds of getting a defective part?? either the cdi or the optimizer?? any1 ever get a defective part? thanks for the help guys.
 
1 - 7 of 7 Posts
Top