ATV Torture Forums banner
problems
1-10 of 13 Results
  1. Honda Forum
    My 2007 Honda 420 rancher has shifting problems. When I first start it it will shift no probs after a bit it will not shift. If I let it sit for a few hours it will shift again for a bit then same prob.The gear display blinks 2 slow and 4 fast blinks or sometimes 2 slow and 2 fast. Any ideas any...
  2. Can-Am/BRP Forum
    I went to move my 2007 Outty 400 today and I couldn't get it to shift properly. When it is on the top side of the Neutral notch it is in Neutral and when it is between Park and Reverse it is in Reverse. Also, the only gears that show on the display are R and N. No park, hi or lo. Any ideas?
  3. Kawasaki Forum
    i have a 04 prairie 700. i am having a problem will acceleration, it is just real sluggish, but i will get bursts of power, and at times it will run just fine, and others it acts like i have no power. if i sink the atv up to the seat in water it seems to run better. is there any electrical...
  4. Comments, Suggestions & Questions
    I have a 99' Yamaha Kodiak and the choke lever broke. I need a picture of the gauges so i know what it looks like. If anyone can find one for me or tell what i should do to it to use it that'd be AWESOME. I added a picture so you know what im talking about.
  5. Polaris Forum
    Last week i was on a ride and my stalled a couple of times. it started right away each time so i thought it would clear its self out. we came up to a fairly good holr so i eased into it and gave her some throttle while in the hole. it died. we hug it from a tree and got all the water draind...
  6. Yamaha Forum
    A friend has a 2004 Grizz 660. He runs a self modified air box with a pre filter and an HMF Utility w/out the QC. This really opened up the machine and I constantly warned him that he was probably running too lean. However, the machine ran really strong. After some time, the quad has started...
  7. Electrical & Lighting
    Honda Rancher 350 ES shifter problems by papawrancher: Owning a 2006 Honda 350 ES I had heard stories of disgruntled owners with electric shift problems just trading off their machines to rid themselves of the problem. I had mine about one year with 1,000 miles on my machine when my problems...
  8. Kawasaki Forum
    ::confused::Well I don't know what to say. I have a problem with my BF 750 back firing at idle and low speed, but at higher speed or choked it does not back fire. Also when backing off the throtle it tends to back fire. Could the carbs be gummed up? Need some advice on trying to solve this problem.
  9. Kawasaki Forum
    I have a 2006 Brute Force 750. I need help trying to find the problem with my cooling fan. the BF over heats because the fan does not turn on. I need help on where to begin to look for the problem. Any ideas will be appreciated greatly. Thanks.
  10. Comments, Suggestions & Questions
    I've been having problems for the past couple of days getting the site to load? Is there something going on? I do not erase cookies very often.
1-10 of 13 Results
Top