09 xp 850 no power need help!! - ATV Torture Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-07-2011, 08:46 PM Thread Starter
Points: 542, Level: 10
Points: 542, Level: 10 Points: 542, Level: 10 Points: 542, Level: 10
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2009
Posts: 2
09 xp 850 no power need help!!

So a little history... Took this into my dealer about 6 months ago for lacking power, it would only pull about 6400 rpms. They did some clutch work and told me it had sucked some dirt and needed a valve job, at this time no blue smoke they changed the oil and said to go ahead and use it because it still runs fine and your not gonna hurt anything else. Then about 200 miles later it started smoking horribly and before i got back home it spun a rod bearing.

So now i have pulled the motor and completly rebuilt it.. New pistons new rods all new bearings new crank, had the cylinders and head checked and adjusted the valves. Put it all back together and it runs great starts right up idles normal, no smoke but it still wont pull rpms, almost sounds a little doggy like the ignition timing is off but i have been told this is not adjustable? I found a spec for it in the service manual at 6 degrees btdc but nothing else on how or if its adjustable or setable by any means.


Im at a loss as to why it wont go past 62 or 6300 unless the dealer screwed up my clutches wich he is sure they are fine. Any and all ideas and input would be greatly appreciated as i have just spent about 1500 dollars on this thing and really cant afford to randomly throw parts at it.
cornicejumper is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-04-2012, 07:42 AM
New Member
Points: 2,139, Level: 27
Points: 2,139, Level: 27 Points: 2,139, Level: 27 Points: 2,139, Level: 27
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Smoothbassman's Avatar
 
Join Date: Feb 2009
Location: York, PA
Posts: 100
This is very interesting. Did you solve it yet?

2011 Sportsman 850 XP EPS Touring
2007 Honda Recon
2009 Dodge Ram


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Smoothbassman is offline  
post #3 of 4 (permalink) Old 02-04-2012, 07:43 AM
New Member
Points: 2,139, Level: 27
Points: 2,139, Level: 27 Points: 2,139, Level: 27 Points: 2,139, Level: 27
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Smoothbassman's Avatar
 
Join Date: Feb 2009
Location: York, PA
Posts: 100
Did you figure out the problem yet?

2011 Sportsman 850 XP EPS Touring
2007 Honda Recon
2009 Dodge Ram


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Smoothbassman is offline  
 
post #4 of 4 (permalink) Old 02-04-2012, 04:37 PM Thread Starter
Points: 542, Level: 10
Points: 542, Level: 10 Points: 542, Level: 10 Points: 542, Level: 10
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2009
Posts: 2
Yes it was the fuel pump, it was about 4psi off the book spec. I put a fuel pump in it out of a 2001 kia optima as polaris wont sell just a pump, they sell the whole fuel tank as a unit for somewhere between 5 and 600 dollars, the pump i got cost me about 60 dollars and works great!!!
cornicejumper is offline  
Reply

Bookmarks

Tags
850 , power

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Torture Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome