850 xp big problems - Page 2 - ATV Torture Forums
ATV Torture Forums

Go Back   ATV Torture Forums > ATV & UTV Forums by Brand > Polaris Forum

Notices

Polaris Forum Polaris

» Site Navigation
» Home
 > FAQ
 > Garage
» ----------------------
» Affiliates
» ----------------------
» View us On
» Featured Product
New Page 3
  Get Registered Today!

Click Here to Register

 
Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old 06-03-2009, 08:29 PM
GRIZZLYWIZARD's Avatar
The Boss
ADMIN
 
Join Date: Sep 2007
Location: Home
Posts: 3,572
That's great news!
Reply With Quote
Sponsored Links
Advertisement
 
  #12 (permalink)  
Old 06-20-2009, 02:11 PM
Points: 26, Level: 1
Points: 26, Level: 1 Points: 26, Level: 1 Points: 26, Level: 1
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2009
Location: alliston ontario
Posts: 5
well i got it back in 1 week and it runs great cost me 40 dollars for oils my dealer was awesome his mechanic is building me a snorkal kit
Reply With Quote
  #13 (permalink)  
Old 06-20-2009, 02:19 PM
BATTLEGUN's Avatar
THE ENFORCER
ADMIN
 
Join Date: Jan 2008
Location: Virginia
Posts: 2,037
That's awesome news bro. And quite possibly the first positive Polaris warranty story I've heard. I'm glad you got your ride back.
Reply With Quote
  #14 (permalink)  
Old 08-07-2009, 06:08 PM
Smoothbassman's Avatar
New Member
Points: 1,033, Level: 17
Points: 1,033, Level: 17 Points: 1,033, Level: 17 Points: 1,033, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2009
Location: York, PA
Posts: 98
Wow,

That's great that you got it covered by warranty. I haven't had not one problem with my XP since I got it.

Well just one problem. My boys can't keep up on the trails!!!!!!
__________________
2011 Sportsman 850 XP EPS Touring
2007 Honda Recon
2009 Dodge Ram

Reply With Quote
  #15 (permalink)  
Old 12-17-2009, 03:00 PM
Points: 188, Level: 3
Points: 188, Level: 3 Points: 188, Level: 3 Points: 188, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2009
Location: Minnesota
Posts: 3
2009 Polaris 850 XP More Big Problems

My machine also has 28 Hours, and I just got it back at 25 Hours from the Warranty Service appointment. This morning at 28 Hours (All in Low Range and under 10 mph) It made a dull exploding sound and started blowing white smoke and there is oil all over the side of the engine coming from up on top somewhere. Looks really bad. Immediately trailered the ATV and took it back to Dealer in Maple Plain. Waiting for a call. Never had a blown engine and this is my fourth Sportsman since 1999. I think I've got one now... Must be a design issue.
Reply With Quote
  #16 (permalink)  
Old 12-17-2009, 05:04 PM
GRIZZLYWIZARD's Avatar
The Boss
ADMIN
 
Join Date: Sep 2007
Location: Home
Posts: 3,572
Quote:
Originally Posted by ISX Design View Post
My machine also has 28 Hours, and I just got it back at 25 Hours from the Warranty Service appointment. This morning at 28 Hours (All in Low Range and under 10 mph) It made a dull exploding sound and started blowing white smoke and there is oil all over the side of the engine coming from up on top somewhere. Looks really bad. Immediately trailered the ATV and took it back to Dealer in Maple Plain. Waiting for a call. Never had a blown engine and this is my fourth Sportsman since 1999. I think I've got one now... Must be a design issue.
Wow, keep us updated on the repair and how the warranty experience goes.
Reply With Quote
  #17 (permalink)  
Old 12-17-2009, 06:11 PM
Smoothbassman's Avatar
New Member
Points: 1,033, Level: 17
Points: 1,033, Level: 17 Points: 1,033, Level: 17 Points: 1,033, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2009
Location: York, PA
Posts: 98
Woah! Keep us informed. I need to know what the issue was so I can watch out for it with my unit.

I know that there was a recall on a crankcase breather valve in July. They claimed that the broken valve could trap water inside and freeze in cold temps resulting in blown engines. When I found out about the recall I called my dealer and they didn't even know that there was a recall out!! They got the repair kit in a week later and had me fixed in twenty minutes.

Whatever it is I hope it's covered by the warranty!!!
__________________
2011 Sportsman 850 XP EPS Touring
2007 Honda Recon
2009 Dodge Ram

Reply With Quote
  #18 (permalink)  
Old 12-07-2010, 02:48 PM
Points: 188, Level: 3
Points: 188, Level: 3 Points: 188, Level: 3 Points: 188, Level: 3
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2009
Location: Minnesota
Posts: 3
Unhappy Polaris 850 Blew Up Again...

Here it is less than 1 year later and my machine on December 5, 2010, did exactly the same thing that it did at 28 Hours a year ago on December 17, 2009. Blew the Valve Cover Seal on top of engine and blew oil smoke and oil all over the footplates. Last time they said the rebuild was covered by warranty... This time, same repeat of incident but I don't know about warranty.

Machine is back at dealer in Maple Plain, MN. Temp was about 20 Degrees and it was started and warmed at idle for 6-10 Minutes before slow roll up driveway at under 10 mph. Blew after 60 seconds. I wonder if there is a recall for valve cover pressure or water vapor plugging up something. It's spooky to run in cold weather which is stupid for their most expensive machine...

Brian
Reply With Quote
  #19 (permalink)  
Old 12-07-2010, 05:09 PM
BATTLEGUN's Avatar
THE ENFORCER
ADMIN
 
Join Date: Jan 2008
Location: Virginia
Posts: 2,037
Quote:
Originally Posted by ISX Design View Post
Here it is less than 1 year later and my machine on December 5, 2010, did exactly the same thing that it did at 28 Hours a year ago on December 17, 2009. Blew the Valve Cover Seal on top of engine and blew oil smoke and oil all over the footplates. Last time they said the rebuild was covered by warranty... This time, same repeat of incident but I don't know about warranty.

Machine is back at dealer in Maple Plain, MN. Temp was about 20 Degrees and it was started and warmed at idle for 6-10 Minutes before slow roll up driveway at under 10 mph. Blew after 60 seconds. I wonder if there is a recall for valve cover pressure or water vapor plugging up something. It's spooky to run in cold weather which is stupid for their most expensive machine...

Brian
Smoothbassman posted something about a recall above. I'd make sure they (the dealer) fixed that. I really hope it works out for ya. Sorry for the run of bad luck.
Reply With Quote
  #20 (permalink)  
Old 12-17-2010, 08:06 AM
Smoothbassman's Avatar
New Member
Points: 1,033, Level: 17
Points: 1,033, Level: 17 Points: 1,033, Level: 17 Points: 1,033, Level: 17
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2009
Location: York, PA
Posts: 98
You should be covered for a repeat of the same issue. Normally they find some way to try and get out of it by saying something else occurred. Stay on them until it is fixed.
__________________
2011 Sportsman 850 XP EPS Touring
2007 Honda Recon
2009 Dodge Ram

Reply With Quote
Reply

Bookmarks

Tags
850, big, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

» Log in
User Name:

Password:

Not a member yet?
Register Now!
» Forum Search
Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 04:40 AM.



Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.